[7/9] media: atomisp: Change ISP subdev name to "ATOM ISP"

Message ID 20240217112438.15240-8-hdegoede@redhat.com (mailing list archive)
State Accepted
Headers
Series media: atomisp: Changes for libcamera support |

Commit Message

Hans de Goede Feb. 17, 2024, 11:24 a.m. UTC
  Change the generic "ATOMISP_SUBDEV" name to "ATOM ISP" to make clear
that this is the subdev for the ISP itself.

Signed-off-by: Hans de Goede <hdegoede@redhat.com>
---
 drivers/staging/media/atomisp/pci/atomisp_subdev.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
  

Comments

Kieran Bingham Feb. 17, 2024, 4 p.m. UTC | #1
Quoting Hans de Goede (2024-02-17 11:24:36)
> Change the generic "ATOMISP_SUBDEV" name to "ATOM ISP" to make clear
> that this is the subdev for the ISP itself.
> 
> Signed-off-by: Hans de Goede <hdegoede@redhat.com>
> ---
>  drivers/staging/media/atomisp/pci/atomisp_subdev.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/staging/media/atomisp/pci/atomisp_subdev.c b/drivers/staging/media/atomisp/pci/atomisp_subdev.c
> index 8253b6faf8cd..822fe7d129e2 100644
> --- a/drivers/staging/media/atomisp/pci/atomisp_subdev.c
> +++ b/drivers/staging/media/atomisp/pci/atomisp_subdev.c
> @@ -799,7 +799,7 @@ static int isp_subdev_init_entities(struct atomisp_sub_device *asd)
>         int ret;
>  
>         v4l2_subdev_init(sd, &isp_subdev_v4l2_ops);
> -       sprintf(sd->name, "ATOMISP_SUBDEV");
> +       sprintf(sd->name, "ATOM ISP");

Pure bikeshedding, but I'd probably lower the shouting to just 
	"Atom ISP"

Either way saying it's a subdev on a subdev isn't much of a value add so 

Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>

>         v4l2_set_subdevdata(sd, asd);
>         sd->flags |= V4L2_SUBDEV_FL_HAS_EVENTS | V4L2_SUBDEV_FL_HAS_DEVNODE;
>  
> -- 
> 2.43.0
>
  
Andy Shevchenko Feb. 17, 2024, 6:48 p.m. UTC | #2
On Sat, Feb 17, 2024 at 6:00 PM Kieran Bingham
<kieran.bingham@ideasonboard.com> wrote:
> Quoting Hans de Goede (2024-02-17 11:24:36)

...

> Pure bikeshedding, but I'd probably lower the shouting to just
>         "Atom ISP"

You beat me to it, +1.
  
Hans de Goede Feb. 18, 2024, 11:10 a.m. UTC | #3
Hi,

On 2/17/24 17:00, Kieran Bingham wrote:
> Quoting Hans de Goede (2024-02-17 11:24:36)
>> Change the generic "ATOMISP_SUBDEV" name to "ATOM ISP" to make clear
>> that this is the subdev for the ISP itself.
>>
>> Signed-off-by: Hans de Goede <hdegoede@redhat.com>
>> ---
>>  drivers/staging/media/atomisp/pci/atomisp_subdev.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/staging/media/atomisp/pci/atomisp_subdev.c b/drivers/staging/media/atomisp/pci/atomisp_subdev.c
>> index 8253b6faf8cd..822fe7d129e2 100644
>> --- a/drivers/staging/media/atomisp/pci/atomisp_subdev.c
>> +++ b/drivers/staging/media/atomisp/pci/atomisp_subdev.c
>> @@ -799,7 +799,7 @@ static int isp_subdev_init_entities(struct atomisp_sub_device *asd)
>>         int ret;
>>  
>>         v4l2_subdev_init(sd, &isp_subdev_v4l2_ops);
>> -       sprintf(sd->name, "ATOMISP_SUBDEV");
>> +       sprintf(sd->name, "ATOM ISP");
> 
> Pure bikeshedding, but I'd probably lower the shouting to just 
> 	"Atom ISP"

Works for me, I've fixed this in my personal tree.

> Either way saying it's a subdev on a subdev isn't much of a value add so 
> 
> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>

Thank you for this and all the other reviews.

Regards,

Hans
  

Patch

diff --git a/drivers/staging/media/atomisp/pci/atomisp_subdev.c b/drivers/staging/media/atomisp/pci/atomisp_subdev.c
index 8253b6faf8cd..822fe7d129e2 100644
--- a/drivers/staging/media/atomisp/pci/atomisp_subdev.c
+++ b/drivers/staging/media/atomisp/pci/atomisp_subdev.c
@@ -799,7 +799,7 @@  static int isp_subdev_init_entities(struct atomisp_sub_device *asd)
 	int ret;
 
 	v4l2_subdev_init(sd, &isp_subdev_v4l2_ops);
-	sprintf(sd->name, "ATOMISP_SUBDEV");
+	sprintf(sd->name, "ATOM ISP");
 	v4l2_set_subdevdata(sd, asd);
 	sd->flags |= V4L2_SUBDEV_FL_HAS_EVENTS | V4L2_SUBDEV_FL_HAS_DEVNODE;