[-next,v4,0/2] media: cx231xx: Switch to use kmemdup() helper and add two macros

Message ID 20230909083612.1845757-1-ruanjinjie@huawei.com (mailing list archive)
Headers
Series media: cx231xx: Switch to use kmemdup() helper and add two macros |

Message

Jinjie Ruan Sept. 9, 2023, 8:36 a.m. UTC
  Use kmemdup() helper instead of open-coding to simplify the code.

On the other hand, as Andrzej suggested, add EP5_BUF_SIZE and
EP5_TIMEOUT_MS macros to replace the magic constant 4096 and 2000.

changes in v4:
- Add Reviewed-by.
- Replace the other 4 places with EP5_BUF_SIZE.

Changes in v3:
- Adjust the second patch to be the first.
- Update the names of the macros.

Jinjie Ruan (2):
  media: cx231xx: Switch to use kmemdup() helper
  media: cx231xx: Add EP5_BUF_SIZE and EP5_TIMEOUT_MS macros

 drivers/media/usb/cx231xx/cx231xx-417.c  | 9 ++++-----
 drivers/media/usb/cx231xx/cx231xx-core.c | 7 +++----
 drivers/media/usb/cx231xx/cx231xx.h      | 3 +++
 3 files changed, 10 insertions(+), 9 deletions(-)
  

Comments

Hans Verkuil Oct. 2, 2023, 8:51 a.m. UTC | #1
Hi Jinjie,

On 09/09/2023 10:36, Jinjie Ruan wrote:
> Use kmemdup() helper instead of open-coding to simplify the code.
> 
> On the other hand, as Andrzej suggested, add EP5_BUF_SIZE and
> EP5_TIMEOUT_MS macros to replace the magic constant 4096 and 2000.
> 
> changes in v4:
> - Add Reviewed-by.
> - Replace the other 4 places with EP5_BUF_SIZE.
> 
> Changes in v3:
> - Adjust the second patch to be the first.
> - Update the names of the macros.
> 
> Jinjie Ruan (2):
>   media: cx231xx: Switch to use kmemdup() helper
>   media: cx231xx: Add EP5_BUF_SIZE and EP5_TIMEOUT_MS macros
> 
>  drivers/media/usb/cx231xx/cx231xx-417.c  | 9 ++++-----
>  drivers/media/usb/cx231xx/cx231xx-core.c | 7 +++----
>  drivers/media/usb/cx231xx/cx231xx.h      | 3 +++
>  3 files changed, 10 insertions(+), 9 deletions(-)
> 

The v3 series has already been merged into https://git.linuxtv.org/media_stage.git/log/,
so I am marking this series as Obsoleted in patchwork. If you want you can post a new
patch with the v3->v4 diff.

Regards,

	Hans