soc_ov9640: rename ov9640.h to soc_ov9640.h
Commit Message
This avoids confusion with the non-soc-camera ov9640.h.
Signed-off-by: Hans Verkuil <hverkuil-cisco@xs4all.nl>
---
Having two headers by the same name caused a daily build error. Fix this by
renaming the soc_camera ov9640.h header.
BTW, is there any reason why the soc_camera ov9640 driver can't be
removed altogether? It's not used anywhere anymore.
---
drivers/media/i2c/soc_camera/soc_ov9640.c | 2 +-
drivers/media/i2c/soc_camera/{ov9640.h => soc_ov9640.h} | 0
2 files changed, 1 insertion(+), 1 deletion(-)
rename drivers/media/i2c/soc_camera/{ov9640.h => soc_ov9640.h} (100%)
@@ -32,7 +32,7 @@
#include <media/v4l2-common.h>
#include <media/v4l2-ctrls.h>
-#include "ov9640.h"
+#include "soc_ov9640.h"
#define to_ov9640_sensor(sd) container_of(sd, struct ov9640_priv, subdev)
similarity index 100%
rename from drivers/media/i2c/soc_camera/ov9640.h
rename to drivers/media/i2c/soc_camera/soc_ov9640.h