[00/30] media: atomisp: Register only 1 /dev/video# node + cleanups

Message ID 20230513123159.33234-1-hdegoede@redhat.com (mailing list archive)
Headers
Series media: atomisp: Register only 1 /dev/video# node + cleanups |

Message

Hans de Goede May 13, 2023, 12:31 p.m. UTC
  Hi All,

Here is an atomisp patch-series to continue the simplification /
exotic feature removal of atomisp. Specifically this series
makes atomisp register only 1 /dev/video# node.

The other patches are some preparation + follow-up work for
this change, as well as a whole bunch of folow-up clean-ups.

The cleanups focus on removing the various count / users functions
which atomisp used before when there were multiple nodes. This
is preparation work for eventually allowing opening the same
node multipe-times, as is normal for standard v4l2 /dev/video#
nodes.

Regards,

Hans


Hans de Goede (30):
  media: atomisp: Remove res_overflow parameter from atomisp_try_fmt()
  media: atomisp: Remove Continuous capture and SDV run-modes
  media: atomisp: Remove isp->need_gfx_throttle field
  media: atomisp: Drop atomisp_get_css_buf_type()
  media: atomisp: Replace source-pad checks with run-mode checks
  media: atomisp: Register only 1 /dev/video# node
  media: atomisp: Drop atomisp_is_vf_pipe()
  media: atomisp: Rename video_out_preview to video_out
  media: atomisp: Remove source_pad parameter from functions and structs
  media: atomisp: Remove 1 line atomisp_flush_bufs_and_wakeup() helper
  media: atomisp: Remove atomisp_subdev_register_video_nodes() helper
  media: atomisp: Remove a bunch of unused atomisp_css_*() functions
  media: atomisp: Remove unused mipi_frame_size field from
    atomisp_[sub_]device
  media: atomisp: Remove isp_timeout flag
  media: atomisp: Remove atomisp_sensor_start_stream()
  media: atomisp: Simplify atomisp_[start|stop]_streaming()
  media: atomisp: Simplify atomisp_css_[start|stop]()
  media: atomisp: Simplify atomisp_open() and atomisp_release()
  media: atomisp: Simplify atomisp_pipe_check()
  media: atomisp: Turn asd->streaming state tracker into a bool
  media: atomisp: Remove no longer used atomisp_css_flush()
  media: atomisp: Remove atomisp_streaming_count()
  media: atomisp: Simplify atomisp_isr() and recovery_work()
  media: atomisp: Rename atomisp_destroy_pipes_stream_force() to
    atomisp_destroy_pipes_stream()
  media: atomisp: Allow system suspend to continue with open /dev/video#
    nodes
  media: atomisp: Remove atomisp_[sub]dev_users()
  media: atomisp: Remove unused css_pipe_id argument from
    atomisp_css_[start|stop]()
  media: atomisp: Remove unused atomisp_get_css_pipe_id() function
  media: atomisp: Remove in_reset argument from atomisp_css_start()
  media: atomisp: Set asd.subdev.devnode once from
    isp_subdev_init_entities()

 .../media/atomisp/include/linux/atomisp.h     |   5 +-
 .../staging/media/atomisp/pci/atomisp_cmd.c   | 371 ++++++------------
 .../staging/media/atomisp/pci/atomisp_cmd.h   |   8 +-
 .../media/atomisp/pci/atomisp_compat.h        |  41 +-
 .../media/atomisp/pci/atomisp_compat_css20.c  | 283 ++-----------
 .../staging/media/atomisp/pci/atomisp_drvfs.c |   2 +-
 .../staging/media/atomisp/pci/atomisp_fops.c  | 176 +--------
 .../staging/media/atomisp/pci/atomisp_fops.h  |   3 -
 .../media/atomisp/pci/atomisp_internal.h      |   9 -
 .../staging/media/atomisp/pci/atomisp_ioctl.c | 212 ++--------
 .../staging/media/atomisp/pci/atomisp_ioctl.h |   5 -
 .../media/atomisp/pci/atomisp_subdev.c        | 198 ++--------
 .../media/atomisp/pci/atomisp_subdev.h        |  30 +-
 .../staging/media/atomisp/pci/atomisp_v4l2.c  | 120 +-----
 14 files changed, 254 insertions(+), 1209 deletions(-)
  

Comments

Andy Shevchenko May 13, 2023, 8:59 p.m. UTC | #1
On Sat, May 13, 2023 at 3:32 PM Hans de Goede <hdegoede@redhat.com> wrote:
>
> Hi All,
>
> Here is an atomisp patch-series to continue the simplification /
> exotic feature removal of atomisp. Specifically this series
> makes atomisp register only 1 /dev/video# node.
>
> The other patches are some preparation + follow-up work for
> this change, as well as a whole bunch of folow-up clean-ups.
>
> The cleanups focus on removing the various count / users functions
> which atomisp used before when there were multiple nodes. This
> is preparation work for eventually allowing opening the same
> node multipe-times, as is normal for standard v4l2 /dev/video#
> nodes.

As usual
Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>
for non-commented and otherwise depending on your answers. I.o.w. feel
free to add if you are going to address as I suggested.
  
Hans de Goede May 17, 2023, 8:02 p.m. UTC | #2
Hi,

On 5/13/23 22:59, Andy Shevchenko wrote:
> On Sat, May 13, 2023 at 3:32 PM Hans de Goede <hdegoede@redhat.com> wrote:
>>
>> Hi All,
>>
>> Here is an atomisp patch-series to continue the simplification /
>> exotic feature removal of atomisp. Specifically this series
>> makes atomisp register only 1 /dev/video# node.
>>
>> The other patches are some preparation + follow-up work for
>> this change, as well as a whole bunch of folow-up clean-ups.
>>
>> The cleanups focus on removing the various count / users functions
>> which atomisp used before when there were multiple nodes. This
>> is preparation work for eventually allowing opening the same
>> node multipe-times, as is normal for standard v4l2 /dev/video#
>> nodes.
> 
> As usual
> Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>
> for non-commented and otherwise depending on your answers. I.o.w. feel
> free to add if you are going to address as I suggested.

Thank you for all the reviews.

I've pushed a new version of the patches addressing all your
comments and adding your Reviewed-by to:

https://git.kernel.org/pub/scm/linux/kernel/git/hansg/linux.git/log/?h=media-atomisp

Regards,

Hans