LinuxTV Patchwork Device bonding

login
register
mail settings
Submitter Juergen Lock
Date Feb. 16, 2013, 3:46 p.m.
Message ID <20130216154636.GA21094@triton8.kn-bremen.de>
Download mbox | patch
Permalink /patch/16891/
State New
Headers show

Comments

Juergen Lock - Feb. 16, 2013, 3:46 p.m.
Hi!

 Now that I have a spare DVB-S2 tuner (TechniSat SkyStar USB HD
(adapter2); the others on this box are atm Hauppauge Nova-TD model
1172 (adapter 0+1) and TechnoTrend S2-3600 (adapter3) - all USB) I
decided to play with vdr device bonding.  I discovered three things:
(still using vdr 1.7.29, I know I should upgrade... :)

1. The LNB setup OSD menu causes bonding to fail (it's trying to
   bond a DVB-T tuner) if I set the two DVB-S2 tuners as "connected
   to sat cable 1"; it works with "sat cable 2".  Maybe it somehow
   thinks of (one of?) the DVB-T tuner(s) as cable 1 too?

2. The infosatepg plugin doesn't check MaySwitchTransponder() and thus
   grabs a bonded device when it shouldn't, I just patched that in the
   FreeBSD port: (plugin maintainer Cc'd)

	http://svnweb.freebsd.org/ports/head/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp?r1=300896&r2=312357

3. Running with these four tuners (dual DVB-T and the bonded two DVB-S2)
   I get two different deadlocks waiting for cDvbTuner::bondMutex
   after live viewing a DVB-T(!) channel for longer (OSD doesn't
   react anymore and attaching gdb reveals two threads waiting for
   bondMutex) - the following two changes make it work but there
   probably is a better fix:  (patch may apply with offsets; one
   of the problems I think is a lock order reversal with cDvbTuner::mutex
   and bondMutex when cDvbTuner::SetChannel calls back into itself
   with bondMutex held.)


 Thanx,
	Juergen
Klaus Schmidinger - Feb. 18, 2013, 10 a.m.
On 16.02.2013 16:46, Juergen Lock wrote:
> Hi!
>
>   Now that I have a spare DVB-S2 tuner (TechniSat SkyStar USB HD
> (adapter2); the others on this box are atm Hauppauge Nova-TD model
> 1172 (adapter 0+1) and TechnoTrend S2-3600 (adapter3) - all USB) I
> decided to play with vdr device bonding.  I discovered three things:
> (still using vdr 1.7.29, I know I should upgrade... :)
>
> 1. The LNB setup OSD menu causes bonding to fail (it's trying to
>     bond a DVB-T tuner) if I set the two DVB-S2 tuners as "connected
>     to sat cable 1"; it works with "sat cable 2".  Maybe it somehow
>     thinks of (one of?) the DVB-T tuner(s) as cable 1 too?

What does the "Setup/LNB" menu look like on your system?
Does it list only the two DVB-S devices, or all four of them?
Which device numbers does it display?

What does the "DeviceBondings = ..." line in setup.conf look like
in both cases (working/not working)?

You wrote that your DVB-S2 device is "adapter2". Does this mean it
is actually "adaper2/frontend0" and "adapter2/frontend1"?

Have you appliead any patches to VDR?
If so, what happens without them?
Same for plugins.

Klaus
Juergen Lock - Feb. 18, 2013, 10:43 p.m.
In article <5121FBA4.2050108@tvdr.de> you write:
>On 16.02.2013 16:46, Juergen Lock wrote:
>> Hi!
>>
>>   Now that I have a spare DVB-S2 tuner (TechniSat SkyStar USB HD
>> (adapter2); the others on this box are atm Hauppauge Nova-TD model
>> 1172 (adapter 0+1) and TechnoTrend S2-3600 (adapter3) - all USB) I
>> decided to play with vdr device bonding.  I discovered three things:
>> (still using vdr 1.7.29, I know I should upgrade... :)
>>
>> 1. The LNB setup OSD menu causes bonding to fail (it's trying to
>>     bond a DVB-T tuner) if I set the two DVB-S2 tuners as "connected
>>     to sat cable 1"; it works with "sat cable 2".  Maybe it somehow
>>     thinks of (one of?) the DVB-T tuner(s) as cable 1 too?
>
>What does the "Setup/LNB" menu look like on your system?
>Does it list only the two DVB-S devices, or all four of them?
>Which device numbers does it display?
>
>What does the "DeviceBondings = ..." line in setup.conf look like
>in both cases (working/not working)?
>
working:

                            Einstellungen - LNB

DiSEqC benutzen:                     nein
SLOF (MHz):                          11700
Untere LNB-Frequenz (MHz):      9750
Obere LNB-Frequenz (MHz):       10600
Device 3 angeschlossen an Sat-Kabel:    2
Device 4 angeschlossen an Sat-Kabel:    2

        ->
DeviceBondings = 1 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

broken:

                            Einstellungen - LNB

DiSEqC benutzen:                     nein
SLOF (MHz):                          11700
Untere LNB-Frequenz (MHz):      9750
Obere LNB-Frequenz (MHz):       10600
Device 3 angeschlossen an Sat-Kabel:    1
Device 4 angeschlossen an Sat-Kabel:    1

        ->
DeviceBondings = 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

>You wrote that your DVB-S2 device is "adapter2". Does this mean it
>is actually "adaper2/frontend0" and "adapter2/frontend1"?
>
 No the other DVB-S2 tuner is adapter3 (TechnoTrend S2-3600), all four
only have frontend0 no frontend1.

>Have you appliead any patches to VDR?

 Currently the two patches belonging to the iptv and ttxtsubs plugins
and my stb0899 signal strength patch, and of course the FreeBSD
portability patches.

>If so, what happens without them?

 I will have to check that later tho I guess they are unrelated...

>Same for plugins.
>
 I just started vdr with just the xineliboutput plugin (I don't have
an ff card) and got the same

DeviceBondings = 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

when setting both DVB-S2 tuners as ".. connected to sat cable 1".

 I wonder, could this be a result of me running vdr with only the DVB-S2
tuners once and the first 1 in DeviceBondings that I may have set then
simply doesn't get reset when the first two tuners became DVB-T?

>Klaus

 Thanx!
	Juergen
Klaus Schmidinger - Feb. 19, 2013, 9:25 a.m.
On 19.02.2013 01:48, Juergen Lock wrote:
> On Mon, Feb 18, 2013 at 11:52:31PM +0100, Klaus Schmidinger wrote:
>> On 18.02.2013 23:43, Juergen Lock wrote:
>>> In article <5121FBA4.2050108@tvdr.de> you write:
>>>> On 16.02.2013 16:46, Juergen Lock wrote:
>>>>> Hi!
>>>>>
>>>>>     Now that I have a spare DVB-S2 tuner (TechniSat SkyStar USB HD
>>>>> (adapter2); the others on this box are atm Hauppauge Nova-TD model
>>>>> 1172 (adapter 0+1) and TechnoTrend S2-3600 (adapter3) - all USB) I
>>>>> decided to play with vdr device bonding.  I discovered three things:
>>>>> (still using vdr 1.7.29, I know I should upgrade... :)
>>>>>
>>>>> 1. The LNB setup OSD menu causes bonding to fail (it's trying to
>>>>>       bond a DVB-T tuner) if I set the two DVB-S2 tuners as "connected
>>>>>       to sat cable 1"; it works with "sat cable 2".  Maybe it somehow
>>>>>       thinks of (one of?) the DVB-T tuner(s) as cable 1 too?
>>>>
>>>> What does the "Setup/LNB" menu look like on your system?
>>>> Does it list only the two DVB-S devices, or all four of them?
>>>> Which device numbers does it display?
>>>>
>>>> What does the "DeviceBondings = ..." line in setup.conf look like
>>>> in both cases (working/not working)?
>>>>
>>> working:
>>>
>>>                               Einstellungen - LNB
>>>
>>> DiSEqC benutzen:                     nein
>>> SLOF (MHz):                          11700
>>> Untere LNB-Frequenz (MHz):      9750
>>> Obere LNB-Frequenz (MHz):       10600
>>> Device 3 angeschlossen an Sat-Kabel:    2
>>> Device 4 angeschlossen an Sat-Kabel:    2
>>>
>>>           ->
>>> DeviceBondings = 1 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>
>>> broken:
>>>
>>>                               Einstellungen - LNB
>>>
>>> DiSEqC benutzen:                     nein
>>> SLOF (MHz):                          11700
>>> Untere LNB-Frequenz (MHz):      9750
>>> Obere LNB-Frequenz (MHz):       10600
>>> Device 3 angeschlossen an Sat-Kabel:    1
>>> Device 4 angeschlossen an Sat-Kabel:    1
>>>
>>>           ->
>>> DeviceBondings = 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>
>>>> You wrote that your DVB-S2 device is "adapter2". Does this mean it
>>>> is actually "adaper2/frontend0" and "adapter2/frontend1"?
>>>>
>>>    No the other DVB-S2 tuner is adapter3 (TechnoTrend S2-3600), all four
>>> only have frontend0 no frontend1.
>>>
>>>> Have you appliead any patches to VDR?
>>>
>>>    Currently the two patches belonging to the iptv and ttxtsubs plugins
>>> and my stb0899 signal strength patch, and of course the FreeBSD
>>> portability patches.
>>>
>>>> If so, what happens without them?
>>>
>>>    I will have to check that later tho I guess they are unrelated...
>>>
>>>> Same for plugins.
>>>>
>>>    I just started vdr with just the xineliboutput plugin (I don't have
>>> an ff card) and got the same
>>>
>>> DeviceBondings = 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>
>>> when setting both DVB-S2 tuners as ".. connected to sat cable 1".
>>>
>>>    I wonder, could this be a result of me running vdr with only the DVB-S2
>>> tuners once and the first 1 in DeviceBondings that I may have set then
>>> simply doesn't get reset when the first two tuners became DVB-T?
>>
>> I'll have to further look into this, but you might be on to something here.
>> Please stop VDR, set that line to
>>
>> DeviceBondings = 0 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>
>> manually and restart VDR. Does it work then?
>>
> Yeah, looks like.  (I should have tested that earlier... :)

Just one more thing: did you get any log messages regarding device bonding
when it didn't work?

>   Btw did you take a look at the bondMutex vs mutex locking yet?  I've had
> no further deadlocks with the second patch now.

I was a little cnfused about this at first ;-)
Will look into it later.

BTW: you sent your original posting "To" me and "Cc"d the VDR-ML. Therefore my reply
inadvertently only went to you and not to the list. I'm no replying explicitly to the
list. Please send postings only to the list and do not Cc me (unless you only want to
contact me privately).

Klaus
Klaus Schmidinger - Feb. 19, 2013, 9:30 a.m.
On 19.02.2013 10:25, Klaus Schmidinger wrote:
> ...
> BTW: you sent your original posting "To" me and "Cc"d the VDR-ML. Therefore my reply
> inadvertently only went to you and not to the list. I'm no replying explicitly to the

s/no/now/

Those stupid typos appear to be contageous... ;-)

Klaus

> list. Please send postings only to the list and do not Cc me (unless you only want to
> contact me privately).
Juergen Lock - Feb. 19, 2013, 8:35 p.m.
In article <51234507.6090302@tvdr.de> you write:
>On 19.02.2013 01:48, Juergen Lock wrote:
>> On Mon, Feb 18, 2013 at 11:52:31PM +0100, Klaus Schmidinger wrote:
>>> On 18.02.2013 23:43, Juergen Lock wrote:
>>>> In article <5121FBA4.2050108@tvdr.de> you write:
>>>>> On 16.02.2013 16:46, Juergen Lock wrote:
>>>>>> Hi!
>>>>>>
>>>>>>     Now that I have a spare DVB-S2 tuner (TechniSat SkyStar USB HD
>>>>>> (adapter2); the others on this box are atm Hauppauge Nova-TD model
>>>>>> 1172 (adapter 0+1) and TechnoTrend S2-3600 (adapter3) - all USB) I
>>>>>> decided to play with vdr device bonding.  I discovered three things:
>>>>>> (still using vdr 1.7.29, I know I should upgrade... :)
>>>>>>
>>>>>> 1. The LNB setup OSD menu causes bonding to fail (it's trying to
>>>>>>       bond a DVB-T tuner) if I set the two DVB-S2 tuners as "connected
>>>>>>       to sat cable 1"; it works with "sat cable 2".  Maybe it somehow
>>>>>>       thinks of (one of?) the DVB-T tuner(s) as cable 1 too?
>>>>>
>>>>> What does the "Setup/LNB" menu look like on your system?
>>>>> Does it list only the two DVB-S devices, or all four of them?
>>>>> Which device numbers does it display?
>>>>>
>>>>> What does the "DeviceBondings = ..." line in setup.conf look like
>>>>> in both cases (working/not working)?
>>>>>
>>>> working:
>>>>
>>>>                               Einstellungen - LNB
>>>>
>>>> DiSEqC benutzen:                     nein
>>>> SLOF (MHz):                          11700
>>>> Untere LNB-Frequenz (MHz):      9750
>>>> Obere LNB-Frequenz (MHz):       10600
>>>> Device 3 angeschlossen an Sat-Kabel:    2
>>>> Device 4 angeschlossen an Sat-Kabel:    2
>>>>
>>>>           ->
>>>> DeviceBondings = 1 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>>
>>>> broken:
>>>>
>>>>                               Einstellungen - LNB
>>>>
>>>> DiSEqC benutzen:                     nein
>>>> SLOF (MHz):                          11700
>>>> Untere LNB-Frequenz (MHz):      9750
>>>> Obere LNB-Frequenz (MHz):       10600
>>>> Device 3 angeschlossen an Sat-Kabel:    1
>>>> Device 4 angeschlossen an Sat-Kabel:    1
>>>>
>>>>           ->
>>>> DeviceBondings = 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>>
>>>>> You wrote that your DVB-S2 device is "adapter2". Does this mean it
>>>>> is actually "adaper2/frontend0" and "adapter2/frontend1"?
>>>>>
>>>>    No the other DVB-S2 tuner is adapter3 (TechnoTrend S2-3600), all four
>>>> only have frontend0 no frontend1.
>>>>
>>>>> Have you appliead any patches to VDR?
>>>>
>>>>    Currently the two patches belonging to the iptv and ttxtsubs plugins
>>>> and my stb0899 signal strength patch, and of course the FreeBSD
>>>> portability patches.
>>>>
>>>>> If so, what happens without them?
>>>>
>>>>    I will have to check that later tho I guess they are unrelated...
>>>>
>>>>> Same for plugins.
>>>>>
>>>>    I just started vdr with just the xineliboutput plugin (I don't have
>>>> an ff card) and got the same
>>>>
>>>> DeviceBondings = 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>>
>>>> when setting both DVB-S2 tuners as ".. connected to sat cable 1".
>>>>
>>>>    I wonder, could this be a result of me running vdr with only the DVB-S2
>>>> tuners once and the first 1 in DeviceBondings that I may have set then
>>>> simply doesn't get reset when the first two tuners became DVB-T?
>>>
>>> I'll have to further look into this, but you might be on to something here.
>>> Please stop VDR, set that line to
>>>
>>> DeviceBondings = 0 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>
>>> manually and restart VDR. Does it work then?
>>>
>> Yeah, looks like.  (I should have tested that earlier... :)
>
>Just one more thing: did you get any log messages regarding device bonding
>when it didn't work?
>
Sure, I just reproduced it:

	ERROR: can't bond device 3 with device 1 (only DVB-S(2) devices can be bonded)

>>   Btw did you take a look at the bondMutex vs mutex locking yet?  I've had
>> no further deadlocks with the second patch now.
>
>I was a little cnfused about this at first ;-)
>Will look into it later.
>
>BTW: you sent your original posting "To" me and "Cc"d the VDR-ML. Therefore my reply
>inadvertently only went to you and not to the list. I'm no replying explicitly to the
>list. Please send postings only to the list and do not Cc me (unless you only want to
>contact me privately).
>
 Oh, sorry, will try to remember.

 Thanx,
	Juergen
Klaus Schmidinger - Feb. 19, 2013, 9:13 p.m.
On 19.02.2013 21:35, Juergen Lock wrote:
> In article <51234507.6090302@tvdr.de> you write:
>> On 19.02.2013 01:48, Juergen Lock wrote:
>>> On Mon, Feb 18, 2013 at 11:52:31PM +0100, Klaus Schmidinger wrote:
>>>> On 18.02.2013 23:43, Juergen Lock wrote:
>>>>> In article <5121FBA4.2050108@tvdr.de> you write:
>>>>>> On 16.02.2013 16:46, Juergen Lock wrote:
>>>>>>> Hi!
>>>>>>>
>>>>>>>      Now that I have a spare DVB-S2 tuner (TechniSat SkyStar USB HD
>>>>>>> (adapter2); the others on this box are atm Hauppauge Nova-TD model
>>>>>>> 1172 (adapter 0+1) and TechnoTrend S2-3600 (adapter3) - all USB) I
>>>>>>> decided to play with vdr device bonding.  I discovered three things:
>>>>>>> (still using vdr 1.7.29, I know I should upgrade... :)
>>>>>>>
>>>>>>> 1. The LNB setup OSD menu causes bonding to fail (it's trying to
>>>>>>>        bond a DVB-T tuner) if I set the two DVB-S2 tuners as "connected
>>>>>>>        to sat cable 1"; it works with "sat cable 2".  Maybe it somehow
>>>>>>>        thinks of (one of?) the DVB-T tuner(s) as cable 1 too?
>>>>>>
>>>>>> What does the "Setup/LNB" menu look like on your system?
>>>>>> Does it list only the two DVB-S devices, or all four of them?
>>>>>> Which device numbers does it display?
>>>>>>
>>>>>> What does the "DeviceBondings = ..." line in setup.conf look like
>>>>>> in both cases (working/not working)?
>>>>>>
>>>>> working:
>>>>>
>>>>>                                Einstellungen - LNB
>>>>>
>>>>> DiSEqC benutzen:                     nein
>>>>> SLOF (MHz):                          11700
>>>>> Untere LNB-Frequenz (MHz):      9750
>>>>> Obere LNB-Frequenz (MHz):       10600
>>>>> Device 3 angeschlossen an Sat-Kabel:    2
>>>>> Device 4 angeschlossen an Sat-Kabel:    2
>>>>>
>>>>>            ->
>>>>> DeviceBondings = 1 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>>>
>>>>> broken:
>>>>>
>>>>>                                Einstellungen - LNB
>>>>>
>>>>> DiSEqC benutzen:                     nein
>>>>> SLOF (MHz):                          11700
>>>>> Untere LNB-Frequenz (MHz):      9750
>>>>> Obere LNB-Frequenz (MHz):       10600
>>>>> Device 3 angeschlossen an Sat-Kabel:    1
>>>>> Device 4 angeschlossen an Sat-Kabel:    1
>>>>>
>>>>>            ->
>>>>> DeviceBondings = 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>>>
>>>>>> You wrote that your DVB-S2 device is "adapter2". Does this mean it
>>>>>> is actually "adaper2/frontend0" and "adapter2/frontend1"?
>>>>>>
>>>>>     No the other DVB-S2 tuner is adapter3 (TechnoTrend S2-3600), all four
>>>>> only have frontend0 no frontend1.
>>>>>
>>>>>> Have you appliead any patches to VDR?
>>>>>
>>>>>     Currently the two patches belonging to the iptv and ttxtsubs plugins
>>>>> and my stb0899 signal strength patch, and of course the FreeBSD
>>>>> portability patches.
>>>>>
>>>>>> If so, what happens without them?
>>>>>
>>>>>     I will have to check that later tho I guess they are unrelated...
>>>>>
>>>>>> Same for plugins.
>>>>>>
>>>>>     I just started vdr with just the xineliboutput plugin (I don't have
>>>>> an ff card) and got the same
>>>>>
>>>>> DeviceBondings = 1 0 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>>>
>>>>> when setting both DVB-S2 tuners as ".. connected to sat cable 1".
>>>>>
>>>>>     I wonder, could this be a result of me running vdr with only the DVB-S2
>>>>> tuners once and the first 1 in DeviceBondings that I may have set then
>>>>> simply doesn't get reset when the first two tuners became DVB-T?
>>>>
>>>> I'll have to further look into this, but you might be on to something here.
>>>> Please stop VDR, set that line to
>>>>
>>>> DeviceBondings = 0 0 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
>>>>
>>>> manually and restart VDR. Does it work then?
>>>>
>>> Yeah, looks like.  (I should have tested that earlier... :)
>>
>> Just one more thing: did you get any log messages regarding device bonding
>> when it didn't work?
>>
> Sure, I just reproduced it:
>
> 	ERROR: can't bond device 3 with device 1 (only DVB-S(2) devices can be bonded)

Thanks, so at least the final check worked.

Klaus

Patch

--- dvbdevice.c.orig
+++ dvbdevice.c
@@ -476,8 +476,10 @@  void cDvbTuner::SetChannel(const cChanne
                   t->SetChannel(NULL);
               }
            }
-        else if (strcmp(GetBondingParams(Channel), BondedMaster->GetBondingParams()) != 0)
+        else if (strcmp(GetBondingParams(Channel), BondedMaster->GetBondingParams()) != 0) {
+           bondMutex.Unlock();
            BondedMaster->SetChannel(Channel);
+           }
         }
      cMutexLock MutexLock(&mutex);
      if (!IsTunedTo(Channel))
@@ -761,7 +773,12 @@  bool cDvbTuner::SetFrontend(void)
            tone = SEC_TONE_ON;
            }
         int volt = (dtp.Polarization() == 'V' || dtp.Polarization() == 'R') ? SEC_VOLTAGE_13 : SEC_VOLTAGE_18;
-        if (GetBondedMaster() != this) {
+#if 1
+        if (bondedTuner && !bondedMaster)
+#else
+        if (GetBondedMaster() != this)
+#endif
+           {
            tone = SEC_TONE_OFF;
            volt = SEC_VOLTAGE_13;
            }

Privacy Policy